building a transparent bridge on OpenBSD

by bram

  1. get three network cards, two for the bridge, mine are re0, em0 & em1 (re0 = admin connection to serve sshd)
  2. echo ‘dhcp’ > /etc/hostname.re0
  3. echo ‘up’ > /etc/hostname.em0
  4. echo ‘up’ > /etc/hostname.em1
  5. echo  ‘add em0’  > /etc/hostname.bridge0
  6. echo ‘add em1’ >> /etc/hostname.bridge0
  7. echo ‘blocknonip em0’ >> /etc/hostname.bridge0
  8. echo ‘blocknonip em1’ >> /etc/hostname.bridge0
  9. echo ‘up’ >> /etc/hostname.bridge0
  10. vi /etc/sysctl.conf

=> uncomment “#net.inet.ip.forwarding=1”